Not getting any bids following ghost example

Hi there!

I’ve been on an epic journey in looking to try out Akash.

I’ve followed everything along to here:

created_at: "2036154"
order_id:
  dseq: "2036151"
  gseq: 1
  oseq: 1
  owner: akash1kpxknh35rmzcvzdf2ugzcyddszxnn7q2jgdn3t
spec:
  name: westcoast
  requirements:
    attributes:
    - key: organization
      value: ovrclk.com
    signed_by:
      all_of: []
      any_of:
      - akash1365yvmc4s7awdyj3n2sav7xfx76adc6dnmlx63
  resources:
  - count: 1
    price:
      amount: "2000"
      denom: uakt
    resources:
      cpu:
        attributes: []
        units:
          val: "1000"
      endpoints:
      - kind: SHARED_HTTP
      memory:
        attributes: []
        quantity:
          val: "1073741824"
      storage:
        attributes: []
        quantity:
          val: "5368709120"
state: open

But I’m not getting any bids:

bids: []
pagination:
  next_key: null
  total: "0"

I put this up a while ago, because I’ve only had some time to tinker in the evenings. Please let me know what I need to do to get bids!

Hey @staff — what’s the best way to get some help / feedback on this?

1 Like

You should remove the attributes above!

What you should use in your configuration is the following:

attributes:
        host: akash
      signedBy:
        anyOf:
          - "akash1365yvmc4s7awdyj3n2sav7xfx76adc6dnmlx63"

You can learn more about these attributes in the documentation.

@mando222 We should go back and remove the ovrclk.com attribute from all the old SDL files in awesome-akash

Thanks, I got one step further and got bids.

I tried two different providers and got the same message from both when trying to create a lease:

failed to execute message; message index: 0: bid not open

@boris “Bid not open” means the bid you tried to lease is already closed. It’s very likely the bids from the providers closed before you attempted to create a lease. Right now bids time out after 1 minute I believe. What’s your account address? Feel free to book a time to chat here: http://easybook.io

@abozanich This seems to happen to first time users who are following the quick start guide, so perhaps longer bid times are needed

OK. Yeah, 1 minute is not long enough since I’m hand typing this into a terminal and making sure I’m doing things right. Maybe 5 minutes?

I tried one bid, and then others in the list, and there isn’t any feedback to tell me to ask for a lease again as the next step.

In fact, I’d love to just auto-accept a bid within parameters, like “less than X”. I know this stuff is tricky, I’m mainly thinking DX, not whatever economics y’all have to figure out :slight_smile:

I’ll try it again later tonight and attempt to do it “quickly”.

Correcting myself, it’s set to 5 minutes right now. We have a few scripts that auto-accept the lowest bid. We’ve been focused on improving the DX and this timeout is a common friction point for new users.

I recently re-deployed my website (https://skynetvalidators.com/) and it is really easy. Here is a concise deployment steps provided you deployment.yml is correct:

  1. Setup Environment (add this to a script and make it really easy):

AKASH_NODE=http://135.181.60.250:26657
AKASH_CHAIN_ID=akashnet-2
AKASH_ACCOUNT_ADDRESS=akash14s4tlmlvy0vsps05csf8l80m7nqxmau38tehp9
AKASH_KEYRING_BACKEND=os
AKASH_KEY_NAME=skynet-tehp9
AKASH_OSEQ=1
AKASH_GSEQ=1

  1. Deploy Request for Provider to Host Application

akash tx deployment create ./deploy.yml --from $AKASH_KEY_NAME --node $AKASH_NODE --chain-id $AKASH_CHAIN_ID --fees 5000uakt -y

  1. Set AKASH_DSEQ variable. Get the number from the output of step 2.

AKASH_DSEQ=<number from setup 2 output>

  1. View BIDs:

akash query market bid list --owner $AKASH_ACCOUNT_ADDRESS --node $AKASH_NODE --dseq $AKASH_DSEQ -o text

  1. Set AKASH_PROVIDER variable. Get this number from the output of step 4

AKASH_PROVIDER=<number from step 4 output>

  1. Create Your Lease:

akash tx market lease create --from $AKASH_KEY_NAME --fees 5000uakt --owner $AKASH_ACCOUNT_ADDRESS --dseq $AKASH_DSEQ --gseq $AKASH_GSEQ --oseq $AKASH_OSEQ --provider $AKASH_PROVIDER --chain-id $AKASH_CHAIN_ID --node $AKASH_NODE

  1. View Lease. (To make sure we were successful with the steps above):

akash query market lease list --owner $AKASH_ACCOUNT_ADDRESS --node $AKASH_NODE --dseq $AKASH_DSEQ -o text

  1. Upload Manifest (There will be no output to this command):

akash provider send-manifest ./deploy.yml --node $AKASH_NODE --dseq $AKASH_DSEQ --provider $AKASH_PROVIDER --home ~/.akash --from $AKASH_KEY_NAME

  1. Retrieve Deployment Access Details:

akash provider lease-status --node $AKASH_NODE --home ~/.akash --dseq $AKASH_DSEQ --from $AKASH_KEY_NAME --provider $AKASH_PROVIDER

Once again, this is a down and dirty concise instructions to deploy to Akash in 9 steps.

Yeah, the docs are quite good! I didn’t have any problems following them. The awesome-akash templates still need to get fixed.

The key part is viewing the bids and creating the lease relatively quickly. Now that I know, I can probably set aside time to be prepped to do it right away and not get distracted by multi-tasking to something else!