Issue with moving a test site to akash

Thanks!

So, after the change to deploy.yml(port setting) was able to get the site going at:‘http://p14sgc81u5f7h294ml846vakoc.ingress.provider-2.prod.ewr1.akash.pub

I was able get to my test site ‘http://www.testdatk.org/’ linked to akash URI by putting URL redirect entry in namecheap for the domain as per link(Deploy onto Akash : Setting up your Keplr Wallet | by Anthony Rosa | Aug, 2021 | Medium).

Next step was to create ssl/https going via cloudflare.
I went to cloudflare and created two nameservers: mary.ns.cloudflare.com and julio.ns.cloudflare.com
i added these entries under nameservers under custom DNS in namecheap for the domain, now I can get to site as https:// but it says “404 Not Found”

I did change the accept parameter in deploy.yml to the new domain name from what it was earlier.

updated and uploaded it via the deploy.yml which was successful,

So akash website works fine at it orignal URI.
http also worked ok when there was only URL redirects.

But after I did the cloudflare setting for nameserver it doesn’t seem to work, does it take more time or its something else you think?

First few lines from Deploy.yml:

version: “2.0”

services:
web:
image: tushcrypteddocker/tktestweb:latest
expose:
- port: 80
as: 80
accept:
- testdatk.org
to:
- global: true

Infact can ignore this, got it working.

Infact was trying another deployment with an image which was running locally on port 9090.
So I was able to push the docker image created to dockerhub(tushcrypteddocker/dacmtest:latest (image ID-d3c8676e533f).
And further to akash, the process of creating deployment, getting BIDS, confirming lease, and uploading the manifest file was all good.
We got a3cm7k8utp9dl6357eokpp3dig.ingress.provider-2.prod.ewr1.akash.pub as the URL.
but when we go to that it says Bad gateway error 503, any idea what can the the issue?

Below is the deploy.yml file:

version: “2.0”

services:
web:
image: tushcrypteddocker/dacmtest:latest
expose:
- port: 9090
as: 80
accept:
- testdatk.org
to:
- global: true

profiles:
compute:
web:
resources:
cpu:
units: 1
memory:
size: 512Mi
storage:
size: 512Mi
placement:
westcoast:
attributes:
host: akash
signedBy:
anyOf:
- “akash1365yvmc4s7awdyj3n2sav7xfx76adc6dnmlx63”
pricing:
web:
denom: uakt
amount: 5000

deployment:
web:
westcoast:
profile: web
count: 1

Deployment was created under DSEQ: 2617592

Lease was created and active confirmed with: akash1vky0uh4wayh9npd74uqesglpaxwymynnspf6a4
Was able to upload the manifest as well.

Tried to confirm the URL which is as:
Status as below:

{
“services”: {
“web”: {
“name”: “web”,
“available”: 1,
“total”: 1,
“uris”: [
testdatk.org”,
“a3cm7k8utp9dl6357eokpp3dig.ingress.provider-2.prod.ewr1.akash.pub”
],
“observed_generation”: 1,
“replicas”: 1,
“updated_replicas”: 1,
“ready_replicas”: 1,
“available_replicas”: 1
}
},
“forwarded_ports”: {}
}

AKASH_DSEQ=2617592

And logs:
[web-9c7cd786d-c5bl4] /docker-entrypoint.sh: /docker-entrypoint.d/ is not empty, will attempt to perform configuration
[web-9c7cd786d-c5bl4] /docker-entrypoint.sh: Looking for shell scripts in /docker-entrypoint.d/
[web-9c7cd786d-c5bl4] /docker-entrypoint.sh: Launching /docker-entrypoint.d/10-listen-on-ipv6-by-default.sh
[web-9c7cd786d-c5bl4] 10-listen-on-ipv6-by-default.sh: info: Getting the checksum of /etc/nginx/conf.d/default.conf
[web-9c7cd786d-c5bl4] 10-listen-on-ipv6-by-default.sh: info: Enabled listen on IPv6 in /etc/nginx/conf.d/default.conf
[web-9c7cd786d-c5bl4] /docker-entrypoint.sh: Launching /docker-entrypoint.d/20-envsubst-on-templates.sh
[web-9c7cd786d-c5bl4] /docker-entrypoint.sh: Launching /docker-entrypoint.d/30-tune-worker-processes.sh
[web-9c7cd786d-c5bl4] /docker-entrypoint.sh: Configuration complete; ready for start up
[web-9c7cd786d-c5bl4] 2021/09/12 08:53:05 [notice] 1#1: using the “epoll” event method
[web-9c7cd786d-c5bl4] 2021/09/12 08:53:05 [notice] 1#1: nginx/1.21.1
[web-9c7cd786d-c5bl4] 2021/09/12 08:53:05 [notice] 1#1: built by gcc 10.3.1 20210424 (Alpine 10.3.1_git20210424)
[web-9c7cd786d-c5bl4] 2021/09/12 08:53:05 [notice] 1#1: OS: Linux 5.4.0-81-generic
[web-9c7cd786d-c5bl4] 2021/09/12 08:53:05 [notice] 1#1: getrlimit(RLIMIT_NOFILE): 1048576:1048576
[web-9c7cd786d-c5bl4] 2021/09/12 08:53:05 [notice] 1#1: start worker processes
[web-9c7cd786d-c5bl4] 2021/09/12 08:53:05 [notice] 1#1: start worker process 32
.
.
[web-9c7cd786d-c5bl4] 2021/09/12 08:53:05 [notice] 1#1: start worker process 79
unexpected EOF

this will work, try this! You exposed port 80 in your docker image not 9090