Issue with moving a test site to akash

Hi team,
Performing website migration to Akash cloud:
The test web server works fine locally and also after switching the DNS for test site (installed via ngnix) the site can be open, and has a docker image created.
Followed steps as per: Quick Start Guide - Akash Guidebook
Installed akash, created and funded the account wallet.
defined all shell variables.
created the config in deploy.yml(Any example of a docker image compared to local one will help)
Cert created successfully.
created deployment.
input variable for: $AKASH_DSEQ $AKASH_OSEQ $AKASH_GSEQ
bids was open
choose a provider(1st time when we created it it was closed before we can choose, so got that on the second try).
created a lease.
confirmed the lease.
State was active for while then went into paused state.
Manifest was sent.
The URL I got from lease status, tried to open the site on that but it didn’t work

This was output for:akash provider lease-status
{
“services”: {
“web”: {
“name”: “web”,
“available”: 0,
“total”: 1,
“uris”: [
“XXXXXXXXXXXXXXX”,
“vrm06vhqnt8uja5aqu8k9k148k.ingress.provider-2.prod.ewr1.akash.pub”
],
“observed_generation”: 1,
“replicas”: 1,
“updated_replicas”: 1,
“ready_replicas”: 0,
“available_replicas”: 0
}
},
“forwarded_ports”: {}
}

Any idea if this is an issue because the image is not being picked up properly or
any issue with lease creation?

1 Like

Hey, can you please share your repository, image, deploy.yml file! I will look into this.

1 Like

Apologies for the late reply.
Here is my deploy.yml file.


version: “2.0”

services:
web:
image: tushcrypteddocker/akashweb-tk
expose:
- port: 5000
as: 80
accept:
- XXXX.XXXX.XXXX
to:
- global: true

profiles:
compute:
web:
resources:
cpu:
units: 0.1
memory:
size: 512Mi
storage:
size: 512Mi
placement:
westcoast:
attributes:
host: akash
signedBy:
anyOf:
- “akash1365yvmc4s7awdyj3n2sav7xfx76adc6dnmlx63”
pricing:
web:
denom: uakt
amount: 1000

deployment:
web:
westcoast:
profile: web
count: 1
~

The image is docker image of an ngnix server, and is running fine locally.

I have made the image as public on docker.
I’m trying to work out what should be the image path in
Like in one of the example it is: image: ovrclk/lunie-light
Is that path of a docker image or github image.

Also,
When what we specify in image say as below in deploy.yml
“image: tombeynon/akash-hello-world:release-v0.1.1”
how does the file knows it needs to pull from docker or akash site?
And if you can help me to see whats the difference between deploy.yaml and deploy.yml.

SDL of akash network structured in such a way that it knows it needs to pull image from dockerhub.
You have to just type the image with tag and akash sdl will automatically pull the image from dockerhub:

Try it out: akashskynet/deploy2.yml at main · Developer-piyush/akashskynet · GitHub
I recommend you to use akash deployment ui tool as a beginner!

Thanks for that, i did made those changes and created two deployment, but not getting any BIDS for it.
DSEQ: 2386979 and 2386785.

Both are open but I’m not getting any BIDS for them.

akash query market bid list --owner=$AKASH_ACCOUNT_ADDRESS --node $AKASH_NODE --dseq $AKASH_DSEQ
bids:
pagination:
next_key: null
total: “0”

akash query market bid list --owner=$AKASH_ACCOUNT_ADDRESS --node $AKASH_NODE --dseq 2386785
bids:
pagination:
next_key: null
total: “0”

Any idea on why no BIDS is that because of any attribute of the yml file I’m using?

Hey you should try this out once again, you will now get bids:

Your website: Click here

1 Like

I think due to high demand there is increase in price for deployment so for specifying less pricing in deploy.yml you may not get bids!
Try increasing price in your deploy.yml file…

i have updated to deploy.yml file u can check and redeploy…

1 Like

Thanks Piyush, whats the link for akash deployment ui?

1 Like

You can find a list of deploy uis here: Deploy UI Tools
the most used deploy ui at the moment is the one from akashlytics

1 Like

Akashlytics - Deploy

so I created another deployment using the updated deploy.yml. All steps looked fine and I was able to finalize a lease. and send deploy.yml to them.

akash query market lease list --owner $AKASH_ACCOUNT_ADDRESS --node $AKASH_NODE --dseq $AKASH_DSEQ
leases:

  • escrow_payment:
    account_id:
    scope: deployment
    xid: akash1wg7e3cqvn29tn7psc6wedgmzq68yu3hr6juaz7/2400898
    balance:
    amount: “0”
    denom: uakt
    owner: akash1vky0uh4wayh9npd74uqesglpaxwymynnspf6a4
    payment_id: 1/1/akash1vky0uh4wayh9npd74uqesglpaxwymynnspf6a4
    rate:
    amount: “5”
    denom: uakt
    state: open
    withdrawn:
    amount: “0”
    denom: uakt
    lease:
    created_at: “2400920”
    lease_id:
    dseq: “2400898”
    gseq: 1
    oseq: 1
    owner: akash1wg7e3cqvn29tn7psc6wedgmzq68yu3hr6juaz7
    provider: akash1vky0uh4wayh9npd74uqesglpaxwymynnspf6a4
    price:
    amount: “5”
    denom: uakt
    state: active
    pagination:
    next_key: null
    total: “0”

choose provider:
AKASH_PROVIDER=akash1vky0uh4wayh9npd74uqesglpaxwymynnspf6a4

akash provider lease-status --node $AKASH_NODE --home ~/.akash --dseq $AKASH_DSEQ --from $AKASH_KEY_NAME --provider $AKASH_PROVIDER
Enter keyring passphrase:
{
“services”: {
“web”: {
“name”: “web”,
“available”: 1,
“total”: 1,
“uris”: [
“xxxx.xxxxxxx.xxxx”,
“p14sgc81u5f7h294ml846vakoc.ingress.provider-2.prod.ewr1.akash.pub”
],
“observed_generation”: 1,
“replicas”: 1,
“updated_replicas”: 1,
“ready_replicas”: 1,
“available_replicas”: 1
}
},
“forwarded_ports”: {}
}

echo $AKASH_NODE $AKASH_CHAIN_ID $AKASH_KEYRING_BACKEND
http://XX.XX.XX.XX:26657 akashnet-2 os

echo $AKASH_DSEQ $AKASH_OSEQ $AKASH_GSEQ
2400898 1 1

Link should be: http://p14sgc81u5f7h294ml846vakoc.ingress.provider-2.prod.ewr1.akash.pub

But when I go to the link it doesn’t open, says bad ngnix server.
Logs:
ithub logs:
goroutine 1 [running]:
github.com/tendermint/tendermint/config.EnsureRoot(0x0, 0x0)
github.com/tendermint/tendermint@v0.34.9/config/toml.go:35 +0x305
github.com/cosmos/cosmos-sdk/server.interceptConfigs(0xc000ee19e0, 0xc000f497c0, 0x4, 0xc000bdf618)
github.com/cosmos/cosmos-sdk@v0.41.3/server/util.go:193 +0x936
github.com/cosmos/cosmos-sdk/server.InterceptConfigsPreRunHandler(0xc000ee7600, 0xc0000ee000, 0x7fc6b6541e58)
github.com/cosmos/cosmos-sdk@v0.41.3/server/util.go:126 +0x325
github.com/ovrclk/akash/cmd/akash/cmd.NewRootCmd.func1(0xc000ee7600, 0xc0000ea540, 0x0, 0xe, 0x0, 0x0)
github.com/ovrclk/akash/cmd/akash/cmd/root.go:83 +0x4f
github.com/tendermint/tendermint/libs/cli.concatCobraCmdFuncs.func1(0xc000ee7600, 0xc0000ea540, 0x0, 0xe, 0x0, 0x0)
github.com/tendermint/tendermint@v0.34.9/libs/cli/setup.go:118 +0x7c
github.com/spf13/cobra.(*Command).execute(0xc000ee7600, 0xc0000ea460, 0xe, 0xe, 0xc000ee7600, 0xc0000ea460)
github.com/spf13/cobra@v1.1.1/command.go:829 +0x582
github.com/spf13/cobra.(*Command).ExecuteC(0xc000d77b80, 0x2a0ed3d, 0x5, 0xc000c9d660)
github.com/spf13/cobra@v1.1.1/command.go:958 +0x375
github.com/spf13/cobra.(*Command).Execute(…)
github.com/spf13/cobra@v1.1.1/command.go:895
github.com/spf13/cobra.(*Command).ExecuteContext(…)
github.com/spf13/cobra@v1.1.1/command.go:888
github.com/ovrclk/akash/cmd/akash/cmd.Execute(0xc000d77b80, 0x2ff6348, 0xc000e88930)
github.com/ovrclk/akash/cmd/akash/cmd/root.go:117 +0x26d
main.main()
github.com/ovrclk/akash/cmd/akash/main.go:14 +0x2a

Any idea what the issue maybe?

1 Like

Redeploy and wait for two minutes!

1 Like

Hey is your problem solved now?
If you need any more help, feel free to ask!

Will try again in a while, but did you mean that the last deployment was successful?
Because I waited for a while but was still wasn;t able to get the image.

This seems to be only for Window/MACOS, we are trying to deploy from a linux system.

The deploy.yml you have has port 80 as 80, should that not be 5000 as 80, I’m running my server locally on that port.
expose:
- port: 80
as: 80
to:
- global: true

Also, any suggestion on having ‘https’ in docker image, running the site locally doesn’t have https enabled so thats why when the migration of that to akash cloud is going to http link.
But, the certificate is enable for that domain so when I actually go that site it an https:

Not sure if we first need to enable https on docker image and then migrate or if we switch the current Domain to point to the akash uri instead of our localhost that would solve the issue?

for https you should use custom link which can be linked to your akash uri through cloudflare: In you docker image i saw you expose port 8000 thats why i recommend using 80…

Thanks for that, any links to article which can help in setting up https:// on docker.

Just to confirm the site running at: “http://ukq2ar4kule8f5loa6qj2dag18.ingress.provider-0.prod.ams1.akash.pub/
Is using deploy.yml of: “akashskynet/deploy2.yml at main · Developer-piyush/akashskynet · GitHub