Error: certificate has not been committed to blockchain

**Describe the issue **: After I have created a certificate client I run the command to deploy and am getting the following error “Error: certificate has not been committed to blockchain”

**Account address **:
**Deployment sequence **:

**Your deploy.yaml file **:

**Do you have more than one deployment group? **:

**Group sequence **:

Is this specific to a provider?:

Provider address :

You can usually resolve this by re-submitting the certificate with akash tx cert create client.

I’ve tried that and it is still giving me the same error.

Someone please help I am still stuck on this problem

Hey, i just checked your address and it seems like you created a certificate on 2021-07-15 but revoked it on 2021-07-20. I don’t see any failed Certificate related transactions after.
It seems like there is no certificate on chain at the moment and i would suggest to follow the certificate creation steps from the docs again. You can find it here: Deploy your App - Akash Guidebook
If the error still persists you may try to deploy with a Deploy UI. I use a deploy ui most of the times too and it makes deploying much easier. You can find a list of deploy uis here: Everyone’s a Winner in the Sovrynthon Hackathon

I tried to start from scratch to create the certificate again but I am still running into the error “certificate hasn’t been committed to blockchain”. I am going to look into the Deploy UI.

I saw for the Akashlytics that it is only available for Windows and macOS. Do you know if there is a way I can download it on Linux?

I think there is no linux version yet. But you can try this deploy ui which works through docker: GitHub - tombeynon/akash-deploy: Akash deploy UI and wallet management

(Shameless plug) Another option is to check out my deploy website: Akash Deploy UI Challenge (SpacePotato) - #3 by SpacePotato. You would need to use Chrome (probably works with Brave too, but untested) with Keplr.